Cant upload pics

I was getting ready to upload my first cel and I got the Post Processing error. It's stuck at 0% and I made sure it was a JPEG and it was less than 1mb. Does anyone have any solutions? I tried different browsers as well, no luck. In the case this thread errors out you can contact me at my gallery eric.rubberslug.
Eric's Gallery
Aug 06 at 7:58 PM
Make sure the width of the image is less than 2500px.
Edited Aug 06 at 11:59 PM
RePete's Gallery
Aug 06 at 11:59 PM
The dimensions of my pic are 600x500 . It still wont upload :(
Eric's Gallery
Aug 07 at 9:16 AM
Same. I've been trying for the past couple hours and images won't upload. This, sadly, is a common problem on RS from time to time. I'm not sure how it's remedied though. Does Jason need to do something for it to work again...?
Shadows on White
Aug 07 at 9:28 AM
I just tried a test upload and it doesn't work for me either.

It's very frustrating. I don't want to see Rubberslug and it's treasure throve of cel images disappear from the net, but this half assed website, free or not, really isn't working either.
Royal Crimson
Aug 07 at 11:09 AM
Welcome! Login or Register